LAUNCH TECH USA 1-877-528-6249 SUPPORT@LAUNCHTECHUSA.COM

Members Login
Chatbox
Please log in to join the chat!
Post Info TOPIC: 2004 c230 K not communicating with Launch CRP123


Newbie

Status: Offline
Posts: 2
Date: Jan 19, 2016
2004 c230 K not communicating with Launch CRP123
Permalink  
 


Hello All, I hope I am putting this in the right place.  I'm currently working with tech support, but wanted to see if any of you had any suggestions.

I have a 2004 c230 K that has/had a few errors.  It had an srs light, has an esp light, has occasionally a check engine light.

I bought the crp123 to clear all the errors I could and diagnose what might be wrong.  When I connect the crp123 and do the auto scan with odb then it fails on all the connection attempts and can't talk to my Benz.  When I did a manual check and select the Benz > 203-c Class (up to 08/2003)” then I was able to reset the srs error codes.  Very awesome!  The problem is that I have tried almost every year and model of Mercedes in the crp123 and can't talk to the esp, transmission, or engine.  Nothing but the airbag system will respond to the device.

I have a very cheap odb2 Bluetooth device and it can talk to my benz just fine.  It lets me clear engine errors and monitor the car. 

I have also tried my crp123 on my 2006 Acura MDX and it works perfectly.  Talks to every system, automatically connects and is very nice.

So, do any of you have any suggestions?  The device works as proved by my acura, it can talk to the Mercedes as proved by the srs error clearing, the odb port on my Benz works as proved by the cheap Bluetooth device, and the crp123 has all the recent updates.  Any idea why it won't really communicate with my Benz?

Thanks



__________________


Veteran Member

Status: Offline
Posts: 34
Date: Jan 22, 2016
Permalink  
 

I have never used my crp123 on a benz but i have the launch pad 2 and needed to use to oem plug under the hood in order to communicate. Does the bluetooth scanner specify the protocol it connects with? I think that year benz is can...

__________________


Newbie

Status: Offline
Posts: 2
Date: Jan 22, 2016
Permalink  
 

Thanks for the reply. I'm not sure on how the bluetooth communicates. I'm using the android torque app and it finds it automatically. I'll check it the next time I get a chance.

Is there a way to specify with the crp123 which communication protocol to use?

As for the oem plug, I'm not sure if the 2004 model has one. I think mercedes started just using the odb port sometime between 2000 and 2004, but I'm not an expert. That's just what the internet seems to be saying :).

__________________


Veteran Member

Status: Offline
Posts: 34
Date: Jan 26, 2016
Permalink  
 

You could be right, the benz i worked on was a late 96. When you use the generic obd function, it scans all protcols. If its not connecting but something else does, check the pins on both sides of the crp123 cable. As long as you are getting reliable info from the other scanner, the Launch should connect via generic.

__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.